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1 Introduction 
These release notes document the changes in 3-SDU version 5.20. Please read 
these release notes in their entirety before installing 3-SDU 5.20. For details on 
upgrading systems using the network download feature see “10 Installing and 
upgrading to 3-SDU 5.20” on page 20. 

We may use “x” in a model number to indicate several generations of the 
product. For example, 3-CPUx represents the 3-CPU, 3-CPU1, and 3-CPU3. 
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1.1 New software versions 
3-SDU 5.20 includes updated firmware for the products listed in Table 1.  

Table 1: New software and microcode versions for 5.20 

Description Version 

C-CPU microcode (for EST3X) 1.20 

C-CPU boot loader microcode (for EST3X) 1.20 

3-CPU microcode (for EST3) 5.20 

3-SxDC1 microcode 5.20 
 

1.2 Contacting Technical Support 
Contact Technical Support if you encounter any difficulties during this installation. 
Please make sure you have diagnostic or log files ready before you contact us. 

Edwards 
8985 Town Center Parkway 
Bradenton, FL 34202 

Tel +1 800 655 4497 
Fax +1 866 226 2126 
est.techsupport@fs.utc.com 
www.edwardsutcfs.com 

2 Operating system compatibility 
3-SDU 5.20 is compatible with the following versions of Microsoft Windows: 

• Windows XP (32-bit), Service Pack 3 

• Windows Vista (32-bit), Service Pack 1 

• Windows 7 (32-bit) 

• Windows 7 (64-bit) 

Note: 3-SDU 5.20 must be “run as administrator,” and requires full elevated 
rights and privileges. 

mailto:est.techsupport@fs.utc.com?subject=270729
http://www.edwardsutcfs.com/
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3 What’s new in 3-SDU 5.20 
New features and updates in this release include: 

• Support for SIGA2-PHS detectors in additional EST3 marketplaces 

• Support for SIGA2 CO detectors (COS, HCOS, PCOS and PHCOS) in 
additional EST3 marketplaces  

• Support for DS and DH nonmapping detectors in additional EST3 
marketplaces 

• Support for DS and DH nonmapping detectors in the EST3X International 
marketplace 

• Improved 3-CPU message handling to reduce network traffic 

• Support for the Gateway III protocol for EST3X 

• Interlockfeedback device type configuration for CT2 and MCT2 modules in 
the China marketplace 

• R-Series annunciator password changes for EST3X 

• Support for SIGA-HCOS detector rate-of-rise operation 

• Calibrate Analog menu for the New Zealand marketplace 

• Improved SIGA2-COS detector background reconcile 

• Inhibit Normal LED Flash Bypass pseudo point message displays 

• Translation updates 

• Additional resolved 3-SDU issues 

3.1 Support for SIGA2-PHS detectors in additional EST3 marketplaces 
Support for SIGA2-PHS detectors has been added to the following EST3 
marketplaces: 

• Arabic Local 
• Arabic Prop 
• Asia Local 
• Asia Prop 
• Australian AS4228 
• Australian AS7240 
• China Local (3-LCDXL(C) only) 
• China Prop (3-LCDXL(C) only) 
• European 
• Mid East Local 
• Mid East Prop 
• New Zealand 
• Singapore 
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• International Local 
• International Prop 

Note: This includes the addition of the Sensor Bypass menu in the control panel 
Activate and Restore menus. 

3.2 Support for SIGA2 CO detectors (COS, HCOS, PCOS and PHCOS) in 
additional EST3 marketplaces 
Support for SIGA2-COS, -HCOS, -PCOS, and -PHCOS detectors have been 
added to the following EST3 marketplaces:  

• Arabic Local 
• Arabic Prop 
• Asia Local 
• Asia Prop 
• Mid East Local 
• Mid East Prop 
• New Zealand 
• Singapore 
• International Local 
• International Prop 

Note: This includes the addition of the Gas Accel Response menu in the control 
panel Activate and Restore menus. 

3.3 Support for DS and DH nonmapping detectors in additional EST3 
marketplaces 
Support for DS and DH nonmapping detectors has been added to the following 
EST3 marketplaces:  

• Arabic Local 
• Arabic Prop 
• Asia Local 
• Asia Prop 
• Mid East Local 
• Mid East Prop 

3.4 Support for DS and DH nonmapping detectors in the EST3X 
International marketplace  
Support for DS and DH nonmapping detectors has been added to the EST3X for 
the International marketplace.  
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3.5 Improved 3-CPU message handling to reduce network traffic 
3-CPU deviation V04.00.02 functionality has been incorporated into EST3 and 
EST3X to reduce the amount of network traffic by preventing unnecessary 
messages from being distributed. The functionality can be configured on the 
Project Parameters > Operations tab in the 3-SDU. Refer to the 3-SDU Help for 
details.  

Figure 1: Configuring 3-CPU message handling to reduce network traffic 

 
 

3.6 Support for the Gateway III protocol for EST3X 
Support for the Gateway III protocol provides the EST3X panel with a direct 
connection to FireWorks (V1.71 or later), or to a field server bridge for 
communication with a building management system. 

3.7 Interlockfeedback device type configuration for CT2 and MCT2 modules 
in the China marketplace 
A CT2 or MCT2 dual input module can be configured as an Interlockfeedback 
device type, and then configured as an interlock output device. 

3.8 R-Series annunciator password changes for EST3X 
A password can be assigned for each R-Series annunciator connected to a 
cabinet in the network.  
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3.9 Support for SIGA-HCOS detector rate-of-rise operation 
Rate-of-rise operation for a SIGA-HCOS detector can be configured in the  
3-SDU. In the cabinet configuration for the detector personality code, you can 
select either “(65) ROR CO Active 3 - latching” or “(68) ROR CO Active 3 
nonlatching.”  

3.10 Calibrate Analog menu for the New Zealand marketplace 
The Calibrate Analog menu will be available in the New Zealand marketplace 
when 3-EAxC microcode V4.01 is released.  

3.11 Improved SIGA2-COS detector background reconcile 
The panel’s background reconcile of SIGA2-COS detectors prevents the 
restoration of latched events.  

3.12 Inhibit Normal LED Flash Bypass pseudo point message displays 
The Inhibit Normal LED Flash Bypass pseudo point message that is generated 
when the user bypasses the Inhibit Normal LED device flash now displays.  

3.13 Translation updates 
The following control panel messages have been translated: 

• The “Most Recent Event” message has been translated into French Canadian 
(QIT 46556169). 

• All SIGA2 event messages (CO Alarm, CO Supervisory, and CO Monitor) 
have been translated into all languages for EST3 and KPDISP.  

• The Inhibit Normal LED Flash Bypass pseudo point message has been 
translated into China Simplified, China Traditional, Korean, Arabic, and 
Hebrew.  

• The Spanish translation for “Drill” has been changed to “Simulacro” on the 
EST3X Activate and Restore menus. 

3.14 Additional resolved 3-SDU issues 
• The R-Series Annunciators Report correctly displays on the LCD and printer 

output. 

• Service group names are restricted to 20 characters.  

• When exporting Gateway files to FireWorks, all LEDs can be exported by 
checking the new “Export the LEDs” check box on the Export Project for 
FireWorks dialog box. 

• The default LCD for the China marketplace is 3-LCDXLC. 
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• For Microsoft Windows 7 operating systems, the time sync form displays 
correctly in different time zone regions. 

• The user can select the 3-ASUFT rail type in the 3-SDU cabinet configuration 
for the Australian marketplace (AS7240). 

• The 3-IDC8/4 only supports the following levels for the Australian marketplace 
(AS7240): Open Circuit Fault, Normal, and Alarm. 

• The appearance and order of the following mapping data can be configured:  

• Actual and expected: device address, serial number, model, and base 
type 

• Expected: label text and device type 

• For Signature device mapping, after accepting actual data or committing 
expected data, the current map position remains unchanged. 

• The Rules > Compile function displays an error message when a wrong 
object label is detected. 

• The auto CID for an R-Series annunciator generates only one pseudo point 
(Annunciator Communications). 

• The Message Editor in the Object Configuration tables allows you to edit both 
3-LCD and 3-LCDXL messages on systems that have both display sizes. 

• In the object configuration form, pseudo points display the correct card 
number. 

• Phone numbers 1 and 2 in the 3-MODCOM Receiver Properties settings 
accept the “*” (asterisk) character. 

• The 3-SDU will display an error message when a user tries to import a project 
created in a future version of the 3-SDU (QIT 46576513). 

• The 3-SDU import functionality does not automatically convert the  
“Security” device type to “Supervisory” for EST3 cabinets (QIT 46637566). 

• The 3-SDU is updated to address an issue where accepting the actual device 
data for a SIGA-PHS that was configured as a SIGA2-PHS in split 
configuration mode (Photo is Alarmsmoke | Heat is Alarmheat) would cause a 
heat event to be incorrectly generated when the photo was activated. 

• The Gateway/RDU Settings display correctly in the Cabinet Configuration > 
Ports tab when the Gateway Type III port is selected.  

• The correct port configuration is sent to the control panel when the Gateway 
Type III port is selected (QIT 46551835). 
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4 Language support 
The following tables detail the language support available in 3-SDU version 5.20. 

Table 2: Language support on projects containing EST3 panels only  
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Arabic 
(United Arab Emirates)          

X   

Chinese 
(Simplified PRC)      X   

   X 

Chinese 
(Traditional Taiwan)            X 

Dutch 
(Standard - Netherlands)   X          

English 
(Australia)     X    X    

English  
(Britain)   X     X     

English 
(USA) X X X X  X X  X X X X 

Finnish 
(Finland)   X          

French 
(Canada) X X         X  

French  
(France)   X          

German 
(Standard - Germany)   X          

Hebrew 
(Israel) X   X       X  

Italian 
(Italy) X  X        X  

Korean  
(Extended Wansung - 
Korea) 

     
      

X 

Polish 
(Poland)   X          
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Portuguese 
(Brazil) X          X  

Portuguese 
(Standard - Portugal)   X          

Russian 
(Russia) X  X        X  

Slovak 
(Slovakia)   X          

Spanish 
(Mexico) X          X  

Spanish 
(Modern Sort - Spain)   X          

Turkish 
(Turkey) X  X        X  

 

Table 3: Language support on  
projects containing EST3X panels  
only, or a combination of EST3X  
and EST3 panels 

 

 

Language U
S 

C
an
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a 

English (USA) X X 

French (Canada) X X 

Portuguese (Brazil) X  

Spanish (Mexico) X  
 

Note: The KPDISP provides a single layout for use in the markets and languages 
served by the American, European, Middle East, and Australian marketplaces. 
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4.1 Bilingual language character sets (for EST3 panel only projects) 
When selecting a primary and secondary language, both languages must be 
supported in the same font table. 

Table 4: Bilingual character sets 

EST3 code page Bilingual language sets 

1250 (Eastern Europe) Croatian, Czech, English, Hungarian, Polish, Slovak 

1251 (Cyrillic) English, Russian 

1252 (Western Europe) Danish, Dutch, English, Finnish, French, German, Italian, 
Norwegian, Portuguese, Spanish, Swedish 

1254 (Turkish) English, Turkish 

1255 (Hebrew) English, Hebrew 
 

Note: When using English as one of the languages in a code page, it must be set 
as the secondary language on the Configure Project > Operations tab. The 
exception to this is the Western Europe code page, where English can be set as 
the secondary or the primary language. 

4.2 Printer code pages 
The following table shows the DOS code page support required to allow you to 
print in the local language. Since not all of Windows characters are available on a 
DOS printer, some characters may not be supported. 

Table 5: Printer code pages 

EST3 code page Printer code page 

936 (Chinese Simplified) Windows Code Page 936 (GB) 

949 (Korean) Windows Code Page 949 (Extended Wansung) 

950 (Chinese Traditional ) Windows Code Page 950 (Big 5) 

1250 (Eastern Europe) DOS Code Page 852 

1251 (Cyrillic) DOS Code Page 866 

1252 (Western Europe)  DOS Code Page 850 

1254 (Turkish) DOS Code Page 857 

1255 (Hebrew) DOS Code Page 862 

1256 (Arabic UL) DOS Code Page 864 
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5 Software versions and compatibility 
5.1 LRM compatible versions 
You must upgrade all applicable microcode versions to take full advantage of the 
new features offered in 3-SDU 5.20. 

Table 6: 3-SDU 5.20 software compatibility 

LRM Oldest 
version [1] 

Latest 
version 

Medium Part 
number 

3-ASU 1.4 3.4 Web 3-SDU 

3-AADC 1.4 3.41 Web 3-SDU 

3-AADC1 1.4 3.71 Web 3-SDU 

3-CPUx 3.05 5.20 Web 3-SDU 

3-EASC/3-EADC 3.61 4.0 Web 3-SDU 

3-FTCU 1.0 1.2 Chip 190156 

3-FTCU 1.4 3.4 Chip 190254 

3-IDC8/4 1.1 3.6 Chip 190159 

3-LDSM 1.0 3.0 Chip 190153 

3-MODCOM(P) 3.0 3.6 Web 3-SDU 

3-OPS 1.0 3.0 Chip 190158 

3-PPS 1.0 3.63 Chip 190157 

3-BPS 1.0 3.63 Chip 190157 

3-BBC 3.0 3.63 Chip 190157 

3-RS485-A/B  1.5 PAL Chip 190271 

3-RS485-R     

3-SSDC/3-SDDC 1.52 3.32 Web 3-SDU 

3-SSDC1/3-SDDC1 1.52 5.20 Web 3-SDU 

3-SAC 3.1 3.6 Web 3-SDU 

3-ZA15 1.1 [2] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA20A 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA20B 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 
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LRM Oldest 
version [1] 

Latest 
version 

Medium Part 
number 

3-ZA30 1.1 [2] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA40A 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA40B 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA90 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

3-ZA95 1.4 3.6 Chip 190252 

 1.0 1.0 PAL Chip 7400068 

C-CPU 1.06 1.20 Web 3-SDU 

CRC 1.3 1.7 Web 3-SDU 

KPDISP 1.0 1.6 Web 3-SDU 

CDR-3 2.0 3.5 Chip 190071 

RLCD 2.0 2.03 Chip RLCD 

RLCD-C 2.0 2.03 Chip RLCD-C 

RLED 2.0 2.03 Chip RLED 

GCI 2.0 2.03 Chip GCI 

[1] Oldest version still compatible with the current version of 3-SDU. 
[2] Version 1.12 required for stand-alone mode disabled feature. To obtain V1.12, request a 
deviation version for part number 190151 from Technical Support. 
 

Notes  

• All 3-CPUx panels in a network must use the same version of microcode. 
Networks with 3-CPU microcode version 3.0 or later can be upgraded with the 
3-SDU by using the network download function. See “11 Upgrading 
microcode versions” on page 26. 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed 
on the same network as, 3-CPU1 and 3-CPU.  

• 3-FTCU firmware comes in two noninterchangeable forms. Part 190254 
cannot be used to update Part 190156, and vice versa. 
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5.2 3-SDU database compatibility 
Use the 3-SDU 5.20 to generate databases for the LRMs listed in Table 7. 

Table 7: LRM microcode supported by 3-SDU 5.20 

LRM 3-SDU supported microcode versions 

3-AADC V1.4, V3.0, V3.1, V3.41  

3-AADC1 V1.4, V3.0, V3.1, V3.41, V3.6, V3.7, V3.71 

3-ASU V1.4, V3.0, V3.1, V3.4 

3-CPU V3.05, V3.65, V3.75, V4.05, V5.02, V5.03 V5.20 

3-EADC/EADC V3.61, V4.0 

3-MODCOM(P) V3.0, V3.1, V3.11, V3.12, V3.6 

3-SAC [1] V3.1, V3.5, V3.6 

3-SSDC/SDDC V1.52, V2.1, V3.32 

3-SSDC1/SDDC1 V1.52, V2.1, V3.32, V3.6, V3.7, V3.71, V3.75, V3.83, V4.0, V4.02, 4.05, 
V4.10 [2], V5.20 

C-CPU V1.06, V1.07, V1.10, V1.11, V1.20 

CRC [3] V1.3, V1.4, V1.5, V1.6, V1.7 

KPDISP V1.0, V1.1, V1.3, V1.4, V1.5, V1.6 

[1] 3-SAC V3.4 is not supported 
[2] For China and International marketplaces only 
[3] CRC V1.2 is not supported 
 

5.3 LRM and 3-CPU V5.20 microcode compatibility  
The following table identifies the latest version of LRM microcode that is 
compatible with 3-CPUx V5.20 microcode. We recommend that you use the 
latest version of LRM microcode. 

Table 8: LRM and 3-CPU V5.20 microcode compatibility 

LRM Microcode version 

3-AADC V3.41 

3-AADC1 V3.71 

3-ASU V3.4 

3-EASC V4.0 

3-EADC V4.0 

MODCOM(P) V3.6 

3-SAC V3.6 

3-SSDC/3-DSDC V3.32 
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LRM Microcode version 

3-SDDC V3.32 

3-SSDC1/ 
3-DSDC1 

V4.02, V4.05, V4.10 [1], V5.20 

3-SDDC1 V4.02, V4.05, V4.10 [1], V5.20 

C-CPU V1.06, V1.07, V1.10, V1.11, 
V1.20 

CRC V1.7 

KPDISP V1.6 

[1] For China and International marketplaces only 

6 Future 3-SDU software versions and compatibility 
To prepare you for the gradual removal from support for older code bases the 
following EST3 firmware/microcode/databases will be supported in the next SDU 
release (V5.2 replacement). We recommended that you update projects to the 
latest code so you will not need to maintain a version of SDU that supports the 
older code. Support for running two SDU versions is currently supported. 

Table 9: Future LRM and 3-SDU compatibility 

LRM Oldest 
version [1] 

Latest 
version 

Medium Part 
number 

3-ASU 3.1 3.4 Web 3-SDU 

3-AADC 3.41 3.41 Web 3-SDU 

3-AADC1 3.41 3.71 Web 3-SDU 

3-CPUx 4.05 5.20 Web 3-SDU 

3-EASC/3-EADC 4.0 4.0 Web 3-SDU 

3-FTCU 1.0 1.2 Chip 190156 

3-FTCU 1.4 3.4 Chip 190254 

3-IDC8/4 1.1 3.6 Chip 190159 

3-LDSM 1.0 3.0 Chip 190153 

3-MODCOM(P) 3.6 3.6 Web 3-SDU 

3-OPS 1.0 3.0 Chip 190158 

3-PPS 1.0 3.63 Chip 190157 

3-BPS 1.0 3.63 Chip 190157 

3-BBC 3.0 3.63 Chip 190157 

3-RS485-A/B  1.5 PAL Chip 190271 

3-RS485-R     
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LRM Oldest 
version [1] 

Latest 
version 

Medium Part 
number 

3-SSDC/3-SDDC 3.32 3.32 Web 3-SDU 

3-SSDC1/3-SDDC1 3.32 5.20 Web 3-SDU 

3-SAC 3.6 3.6 Web 3-SDU 

3-ZA15 1.1 [2] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA20A 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA20B 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA30 1.1 [2] N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA40A 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA40B 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA90 1.4 3.6 Chip 190252 

 1.4 1.4 PAL Chip 190191 

3-ZA95 1.4 3.6 Chip 190252 

 1.0 1.0 PAL Chip 7400068 

C-CPU 1.06 1.20 Web 3-SDU 

CRC 1.7 1.7 Web 3-SDU 

KPDISP 1.6 1.6 Web 3-SDU 

CDR-3 2.0 3.5 Chip 190071 

RLCD 2.0 2.03 Chip RLCD 

RLCD-C 2.0 2.03 Chip RLCD-C 

RLED 2.0 2.03 Chip RLED 

GCI 2.0 2.03 Chip GCI 

[1] Oldest version still compatible with the current version of 3-SDU. 
[2] Version 1.12 required for stand-alone mode disabled feature. To obtain V1.12, request a 
deviation version for part number 190151 from Technical Support. 
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Notes  

• All 3-CPUx panels in a network must use the same version of microcode. 
Networks with 3-CPU microcode version 3.0 or later can be upgraded with the 
3-SDU by using the network download function. See “11 Upgrading 
microcode versions” on page 26. 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed 
on the same network as, 3-CPU1 and 3-CPU.  

• 3-FTCU firmware comes in two noninterchangeable forms. Part 190254 
cannot be used to update Part 190156, and vice versa. 

Use the 3-SDU 5.20 to generate databases for the LRMs listed in Table 10 
below. 

Table 10: LRM microcode supported by future 3-SDUs 

LRM 3-SDU supported microcode versions 

3-AADC V3.41  

3-AADC1 V3.41, V3.7, V3.71 

3-ASU V3.1, V3.4 

3-CPU V4.05, V5.02, V5.03 V5.20 

3-EADC/EADC V4.0 

3-MODCOM(P) V3.6 

3-SAC V3.6 

3-SSDC/SDDC V3.32 

3-SSDC1/SDDC1 V3.32, V4.0, V4.02, 4.05, V5.20 

C-CPU V1.06, V1.07, V1.10, V1.11, V1.20 

CRC V1.7 

KPDISP V1.6 

7 Microcode updates for 3-CPU V5.20 
This microcode update: 

• Improves the EST3 data network  

• Corrects the acknowledgment of guard patrol events for proprietary 
marketplaces 

• Incorporates improved 3-CPU message handling to reduce network traffic  
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7.1 EST3 data network improvements 
Improvements to the detection of network overflow conditions in the EST3 data 
network reduce the occurrence of network overflow faults during heavy data 
network traffic. 

7.2 Correct acknowledgment of guard patrol events for proprietary 
marketplaces 
The 3-CPU prevents internal faults when acknowledging Guard Patrol events in 
proprietary marketplaces.  

7.3 Improved 3-CPU message handling to reduce network traffic 
3-CPU deviation V04.00.02 functionality has been incorporated and can be 
configured on the Project Parameters > Operations tab in the 3-SDU (see 
Figure 1 on page 5). 

The new configuration settings are designed to reduce the amount of network 
traffic by preventing unnecessary messages from being distributed. Refer to the 
3-SDU Help for details. 

8 Microcode updates for C-CPU V1.20 
This microcode update: 

• Improves the EST3X data network  

• Corrects acknowledgment of guard patrol events for proprietary marketplaces 

• Supports the Gateway III protocol 

• Provides internal loop controller updates  

• Improves communication to R-Series annunciators, rail modules, and printers  

• Provides a message routing configuration pre-check 

• Improves the Instruction Text output 

• Assigns specific Task IDs to supervision tasks 

• Incorporates improved 3-CPU message handling to reduce network traffic  

• Improves the boot up process 

8.1 EST3X data network improvements 
EST3X data network improvements include: 

• Improved network related faults (i.e., network overflow and communication) 
during heavy network data traffic.  

• Improved network communication at the 19.2K baud rate for networks that 
include EST3X and EST3 panels. 
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8.2 Correct acknowledgment of guard patrol events for proprietary 
marketplaces 
The C-CPU prevents internal faults when acknowledging Guard Patrol events in 
proprietary marketplaces.  

8.3 Support for the Gateway III protocol  
The Gateway III protocol is supported on Port 1. This provides a direct 
connection from an EST3X panel to FireWorks (V1.71 or later), or to a field 
server bridge for communication with a building management system.  

8.4 Internal loop controller updates  
The following loop controller updates were made. 

Support for DH and DS nonmapping devices: DS and DH nonmapping 
devices are supported for the International marketplace.  

 

Startup improvements: Improvements to loop startup processing and loop 
messaging efficiency for select device types reduce the average startup time of 
loops; especially, loops that use SIGA2 or nonmapping devices. 

Relay base supervision improvements: Newly modified algorithms provide 
more efficient and thorough supervision of system relay bases. 

8.5 Improved communication to R-Series annunciators, rail modules, and 
printers 

C-CPU V1.20 improves the robustness of communication to the R-Series 
annunciators, rail modules, and mainboard microprocessor, as well as printer 
communication. 

8.6 Message routing configuration verification  
C-CPU V1.20 checks the message routing configuration before sending restoral 
events to the printer.  

8.7 Instruction Text improvements  
Instruction Text improvements include: 

• Corrupted characters in Instruction Text are prevented.  

• All 2,000 characters of Instruction Text, when applicable, will be sent to the 
printer.  

8.8 Specific Task ID assigned to supervision tasks 
In the unlikely event of a watchdog supervision fault, Task IDs are assigned to 
individual supervision tasks so they can be specifically reported. 
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8.9 Improved 3-CPU message handling to reduce network traffic 
3-CPU deviation V04.00.02 functionality has been incorporated and can be 
configured on the Project Parameters > Operations tab in the 3-SDU (see 
Figure 1 on page 5).  

The new configuration settings are designed to reduce the amount of network 
traffic by preventing unnecessary messages from being distributed. Refer to the 
3-SDU Help for details.  

8.10 Improved boot up process 
Boot loader code V1.20 improves the C-CPU application boot up time. 

9 Microcode V5.20 updates for 3-DSDC1, 3-SSDC1,  
3-SDDC1 loop controllers 
This microcode update: 

• Improves DH and DS nonmapping device functionality  

• Improves the loop controller startup process 

• Improves relay base supervision  

• Corrects the handling of stand-alone operations 

• Corrects the flash rate for first detector in alarm 

9.1 DH and DS nonmapping device functional improvements 
This microcode update corrects deficiencies and adds enhancements that enable 
the proper addition and substitution of nonmapping devices to a project. This 
includes adding the Inhibit Normal Flash status to the loop controller status for 
systems configured with the nonmapping devices.  

9.2 Startup improvements 
Improvements to loop startup processing and loop messaging efficiency for 
select device types reduce the average startup time of loops; especially, loops 
that use SIGA2 or nonmapping devices. 

9.3 Relay base supervision improvements 
Newly modified algorithms will provide more efficient and thorough supervision of 
system relay bases. 

9.4 Correct handling of stand-alone operations 
Alarm activations that occur in the first 18 seconds of stand-alone activity are 
processed. 
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9.5 Correct flash rate for first detector in alarm 
The flash rate for the first device in alarm has been corrected in marketplaces 
that support LEDs that do not turn on steady. 

10 Installing and upgrading to 3-SDU 5.20 
10.1 Upgrading 
You must uninstall previous versions of the 3-SDU before installing  
3-SDU V5.20, either by using the shortcut in the Windows Start menu or by using 
the Control Panel. As a best practice, always export and save all projects to a 
backup location before uninstalling the 3-SDU.  

Note: If previous 3-SDU versions are not uninstalled, you will be prompted during 
the new version installation to do so, or to choose a different directory for the new 
version. 

The 3-SDU does not remove the Projects folder during the uninstall process; 
however, the location to which you install the new version affects the list of 
projects shown by 3-SDU V5.20.  

The location of the installation affects your projects as follows: 

• If you are installing into the same directory as the previous installation, the  
3-SDU does not overwrite the old Projects folder, so your existing projects 
remain intact. When you open an existing project, the 3-SDU converts that 
project’s internal database format to work with 3-SDU V5.20.  

• If you are installing into a different directory than the previous installation, the 
Projects folder will be empty. Your old projects still exist in the Projects folder 
of your previous installation directory, but are not accessible from the V5.20 
installation of the 3-SDU. To correct this, after you have finished upgrading to 
3-SDU V5.20, import your existing projects from your backup location. 

10.2 Installation prerequisites 
The only prerequisite for installing the 3-SDU is the HASP device driver. The 
HASP4 installs if you are running on a 32-bit system, while the Sentinel HASP 
installs if you are running on a 64-bit system. 

To begin loading the requirements, double-click the 3-SDU setup.exe file. When 
the Requirements window appears (see Figure 2 on page 21), click the Install 
button, and then step through the HASP installation. 
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Figure 2: The Requirements window 

 

The HASP requirement only appears during a first-time installation. Any 
subsequent installations of the 3-SDU application do not display the HASP 
requirement, because it has been installed previously. 

The 3-SDU application begins installing immediately after the HASP is 
completely installed. 

The HASP does not uninstall if you uninstall the 3-SDU. If you need to uninstall 
the HASP, use the Control Panel. 

10.3 Installing the 3-SDU 
The 3-SDU application begins installing immediately after the HASP requirement 
has installed completely. 

To install the 3-SDU: 
1. Finish loading the HASP requirement, if you have not previously loaded it. 
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2. The 3-SDU installation wizard starts, and displays the welcome page. Click 
Next. 

 
3. The License Agreement page appears. Click Yes to accept the license. 
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4. The Choose Destination Location page appears. Click Browse to select 
another folder or click Next to choose the default path C:\FAST\3-SDU\. 

 
5. The Ready to Install page appears. Click Install to begin transferring files. 
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10.4 Installing the Borland Database Engine 
The Borland Database Engine is installed as a part of the 3-SDU installation. You 
can click Browse to select another folder, or click OK to choose the default path 
C:\Program Files\Common Files\Borland Shared\BDE. While you can install the 
BDE in any location, we do not recommend changing the default path. 

To install the Borland Database Engine: 
1. Do not click the Cancel button, because any attempt to cancel the BDE 

installation generates an error. 

 
2. If the BDE is already installed in the default directory, it overwrites the 

previous installation. You can also install the BDE in multiple directories. 
Neither of these scenarios affects the operation of the 3-SDU application. 

3. If you have another application window open while you are installing the  
3-SDU, the BDE installation window goes behind other active windows. When 
this happens, the 3-SDU installation remains in a wait mode until you activate 
the BDE dialog box again. To do so, select the BDE task from the taskbar and 
continue the installation. The best practice is to close all applications and 
monitor the 3-SDU installation. 

Note: Increase the Zoom in this PDF if you want to see details in this screen 
shot. 
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4. Click on Borland Database Engine in the taskbar to activate it, and then click 

OK. 
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5. After the Borland Database Engine finishes installing, the Finish page 
appears. Click Finish to complete the 3-SDU installation. 

 

11 Upgrading microcode versions  
11.1 3-CPUx version 5.20 
Project version numbers are embedded in each project file. Because the Save As 
command creates a new version number that is different than the embedded 
version, you must use the following procedure to install V5.20. Please follow 
these steps in the correct order to upgrade the hardware and software in your 
system. 

Notes  

• When adding an EST3X panel to an EST3 Network, upgrade your EST3 
microcode to 5.20 before connecting EST3X nodes to the EST3 network. 

• Do not mix different versions of 3-CPUx microcode on the same network. 
Upgrade an existing system by carefully following this procedure. 

To upgrade V3.0 or later to V5.20: 
1. Install 3-SDU version 5.20. 

2. Click Project > Open and select your project from the Open Project dialog 
box. Click OK to open the project. 
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Note: When you open a project, the 3-SDU may give you a warning that 
states “Some or all of this project’s selected MicroCode versions do not exist 
or are incompatible with the Brand or Marketplace. Click OK to update to the 
latest versions or click Ignore and fix the problem manually.” If you click 
Ignore and do not select valid versions of microcode, errors can occur when 
configuring the LRMs. Therefore, if you click Ignore, also go to the Project 
Parameters > MicroCode tab and verify that the selected microcode versions 
are all supported; the 3-SDU highlights in red those versions that are no 
longer supported. 

3. Click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Click Project > Save to save the recompiled project. 

8. Click Tools > Communications and select Network for the Download mode. 

9. From the LRM Type Display Filter group, select 3-CPU. From the File Display 
Filter group, select three options, Boot loader code, Application code, and 
Database for each panel. (Do not select any other option.) 

10. On Class B networks, connect the 3-SDU to the first CPU (sometimes called 
the service panel). On Class A networks you can connect the 3-SDU to any 
node on the network. 

11. Click Download and Start to begin the network download. 

11.2 Upgrading firmware on 3-DSDC(1)(C), 3-SDDC(1)(C), and 3-AADC(1) 
loop controllers 
You must upgrade the 3-CPUxs before upgrading the loop controllers. 

You can upgrade the loop controllers using network downloads. 

If the bootstrap download fails, or if the steps are performed out of order, you 
must cycle the power on the panel and restart the upgrade by downloading the 
bootstrap code again. 

You must complete each of the following steps in separate download sessions. 

To upgrade the loop controllers: 
1. Download the loop controller bootstrap to each LRM. (Download the 

bootstrap only; do not download the application code or database.) 

2. From the LCD, issue a restart command for all panels. 
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3. Download the loop controller application code. 

4. Download the loop controller databases. 

11.3 Upgrading the 3-ASU 
When upgrading the 3-ASU, we recommend that you do so in the following order: 

1. Download the boot code. 

2. Download the application code. 

3. Download the database. 

11.4 Upgrading the CRC 
When upgrading the CRC/CRCXM, we recommend that you do so in the 
following order: 

1. Download the 3-SDU application code. 

2. Download the 3-SDU database. 

3. Download the ACDB database (from the CRC Administration tab, select the 
Destination DB Init task). 

Note: Upgrading the code to a CRC disables the access functionality for the door 
being controlled, until you use the ACDB to download its corresponding 
database. 

11.5 Upgrading from C-CPU 1.0x to V1.20 
Firmware V1.20 is not compatible with older databases (V1.0x firmware). The 
new application and all databases must be downloaded to all panels in the 
system. Do not mix different versions of C-CPU microcode on the same network; 
upgrade an existing system by carefully following these steps. 

Steps to upgrade C-CPU 1.0x to V1.20: 
1. Install 3-SDU V5.20. 

2. Click File > Open and select your project from the Open Project dialog box. 
Click OK to open the project. 

3. On the Project/Microcode tab, select the 1.20 version for C-CPU. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Click File > Save to save the recompiled project. 
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8. Click Tools > Communications and check Network for the download mode. 

9. Select the CPU application code, bootstrap, C-CPU database, and internal 
loop controller database (slot 3) for each panel.  

10. Connect your PC to any CPU node on the network.  

11. Click Download and Start to begin the network download. 

12. After the download finishes and the panels start up, the LCD shows the 
following internal fault: 

“xx000604Internal Fault,” where xx is the panel address 

Restart the network to restore the fault. From any panel in the network, select 
Program Menu > Restart and perform a restart of all panels.  

11.6 Upgrading from C-CPU V1.1x to V1.20 
Download the new database with the 3-SDU V5.20 to take advantage of new 
features.  

Steps to upgrade C-CPU V1.1x to V1.20: 
1. Install 3-SDU V5.20. 

2. Click File > Open and select your project from the Open Project dialog box. 
Click OK to open the project. 

3. On the Project/Microcode tab, select the 1.20 version for C-CPU. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Click File > Save to save the recompiled project. 

8. Click Tools > Communications and check Network for the download mode. 

9. Select the CPU Application code, bootstrap, C-CPU database, and the 
internal loop controller database (slot 3) for each panel.  

10. Connect your PC to any CPU node on the network.  

11. Click Download and Start to begin the network download. 
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11.7 Downgrading C-CPU from V1.20 to V1.0x  
You may want to downgrade a C-CPU version from V1.20 to 1.0x in certain 
situations.  

To downgrade the C-CPU version: 
1. Install V5.20 of 3-SDU.  

2. Click File > Open and select your project from the Open Project dialog box. 
Click OK to open the project. 

3. On the Project/Microcode tab, select the 1.0x version for C-CPU. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Click Rules > Compile to recompile your project. 

6. Click Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Click File > Save to save the recompiled project. 

8. Click Tools > Communications and check Network for the download mode. 

Select the C-CPU application code, the C-CPU database, and the internal 
loop controller database (slot 3) for each panel.  

9. Connect your PC to any CPU node on the network.  

10. Click Download and Start to begin the network download. 

12 Important Information 
When you open a 3-SDU project, you see a Warning message about missing or 
incompatible microcode versions. If you click OK, download the latest firmware 
and boot loader code before downloading the database. Without first 
downloading the application codes, the panel may lock up. 

Figure 3: Missing or incompatible microcode versions warning 
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13 Reminder of NFPA 72 testing requirements 
When changes are made to site-specific software, the following shall apply: 

• All functions known to be affected by the change, or identified by a means 
that indicates changes, shall be tested 100 percent. 

• In addition, 10 percent of initiating devices that are not directly affected by the 
change, up to a maximum of 50 devices, also shall be tested and correct 
system operation shall be verified. 

• A revised record of completion in accordance with NFPA standards shall be 
prepared to reflect these changes. 

• Changes to all control units connected or controlled by the system executive 
software shall require a 10 percent functional test of the system, including a 
test of at least one device on each input and output circuit to verify critical 
system functions such as notification appliances, control functions, and 
off-premises reporting. 

14 Known issues 
The following known issues exist for 3-SDU version 5.20. 

14.1 Windows Vista and Windows 7 
Some features in the 3-SDU require you to run the program with higher privileges 
in the execution level scheme for Windows Vista or Windows 7. However, when 
you run at the higher privilege level, the User Account Control dialog box 
appears. See Figure 4 on page 32. 
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Figure 4: User Account Control 

 

This appears because the 3-SDU is not currently certified with electronic 
signature verification software. Click Allow to run your 3-SDU with full 
functionality. 

14.2 Changes before DB Conversion and download to the panel 
Many changes, such as changing or deleting devices, DACT accounts, etc. that 
are used in a rule can cause serious panel operation problems if you download 
the database directly to the panel. Always compile the rules after you have made 
changes to objects, and before you run a DB Conversion and download the 
database to the panel. 

14.3 Changes made after installation 
If you copy files into the installation directories after the installation, or create files 
while running the 3-SDU, the system does not uninstall those files and the 
directory tree containing them during the uninstall process. This includes all 
project files (by design) and settings used relating to projects. We recommend 
exporting your project files to another location before uninstalling the 3-SDU. 

14.4 QuickStart concurrent installation 
If you install the 3-SDU 5.20 after installing the QuickStart QS-CU, the 3-SDU 
installation overwrites the C:\WINDOWS\system32\dunzip32.dll and 
C:\WINDOWS\system32\dzip32.dll files. The 3-SDU uses newer versions of 
these files that the QS-CU cannot use, so if this happens the import of QuickStart  
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projects into the QS-CU fails. QuickStart will be rebuilt to use the correct files in a 
future release. Either of the following workarounds will solve the issue: 

• Before installing the 3-SDU 5.20, copy the C:\WINDOWS\system32\ 
dunzip32.dll and C:\WINDOWS\system32\dzip32.dll from the Windows 
directory to the QuickStart directory. 

• Manually delete C:\WINDOWS\system32\dunzip32.dll and C:\WINDOWS\ 
system32\dzip32.dll, and reinstall QuickStart after installing the 3-SDU. 

14.5 Fonts and resolution 
You must run the 3-SDU on a computer with a resolution of 1024 x 768 or 
greater and use normal size fonts, that is, DPI setting: Normal size (96 DPI). If 
you use any other font setting the 3-SDU buttons may not be accessible. 

14.6 Using time controls to disable zone groups 
Members of a zone group are not disabled if the zone group is disabled via a 
time control. Do not use time controls to disable a zone group. 

14.7 Time synchronization 
3-CPU Version 03.10.00 has a known issue with the time synchronization 
command. If your system has Time Synchronization > System Time Source set 
to 3-LCD User Interface, then any communication with the 3-CPU causes the 
system to reboot. We recommend that when you use 3-SDU 5.20 you set Time 
Synchronization > System Time Source to Input Circuit. 

14.8 Compatibility with FireWorks version 1.60.xx and earlier 
Fire systems that include Support for SIGA2 with CO or SIGA2 with split sensing 
operation need to ensure that FireWorks software is updated to V1.70 or later for 
proper reporting of CO and split sensing. 

14.9 R-Series remote annunciator group details 
The following functions for R-Series remote annunciators are not enabled at this 
time: 

• Matrix details 

• Service group details 

14.10 Failure to load CPU database causes download mode 
An issue can occur when downloading C-CPU version 1.10 to an EST3X panel 
containing a database that was previously compiled or converted with C-CPU 
V1.0x. 
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When the database in the panel is not compatible with the C-CPU microcode 
version, the panel enters the download mode and displays the following 
messages on its LCD: 

• Download Mode 

• Failed to load CPU database 

• Please download a new CPU database 

When the EST3X panel is in this condition, the Ethernet connection is no longer 
available for the panel. 

To get the panel out of download mode: 
1. Select the appropriate microcode for the CPU. 

2. Compile and convert the database. 

3. Download the database to the CPU using an RS-232 or RJ-11 connection, or 
via another panel in the network. 

If an EST3X panel that resides in a network combined with EST3 panels enters 
this state, all EST3X panels in that network generate an “XX000684Network 
Compatibility Fault.” The XX represents the address of the EST3X panel that 
generated the fault. 

14.11 Saving 3-SDU reports to XLS format in Windows 7 
When displaying a report in the 3-SDU, clicking the Save Report button at the top 
of the screen offers the ability to save the report data in several formats. Due to a 
conflict with Windows 7 and our third-party reporting tool, saving a report to XLS 
(Excel) format produces a corrupt XLS file that cannot be viewed. We 
recommend saving the report to CSV format and then opening the file in Excel. 

14.12 Auto Generate Events CID option requires 3X panels only 
When configuring a 3-MODCOM, the Auto Generate Events option (which 
creates CID events without the need to write rules) only functions for projects 
containing eight or fewer EST3X panels. Once you exceed eight EST3X panels 
or add an EST3 panel, you have to write rules for all CID events.  

14.13 CDR-3 Bell Coder parity 
When using the CDR-3 on an EST3X panel, set the CDR-3 to “no parity” if you 
need extended digit operation. See the CDR-3 Bell Coder Installation Sheet 
(P/N 3100023) for details on the switch options. 
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14.14 EST3 Instruction Text limitation 
For an EST3 system, the last 32 characters of 2,000-character Instruction Text 
do not print. We recommend that you limit the maximum number of Instruction 
Text characters to 1,960. 

14.15 Configuring nonlatching PCOS detector group names 
Do not select “None” for the Group Name for a nonlatching PCOS detector 
configured as a “Supervisory” device type with a relay or sounder base, and 
assigned personality code (55) Photo nonlatching - CO latching or (56) Photo 
nonlatching - CO nonlatching (“Supervisory” device type). If None is selected, the 
detector may not activate the sounder base. 

To configure a nonlatching PCOS detector: 
1. Open the Signature Series Configuration dialog box and click the Loop 

Detectors tab. 

2. In the detectors table, locate the PCOS, and then from the Group Name list 
do one of the following: 

• Select Individual_Control, and then select the appropriate Follow setting. 
Note: You may need to create a rule to control the base, depending on 
your application. 

— or — 

• Select a relay/sounder group (RSG). 

14.16 Manually updating 3-SSDC1 and 3-SDDC1 microcode 
Manually updating the 3-SSDC1\3-SDDC1 Microcode Type in the MicroCode 
dialog box when the CPU microcode is unavailable may result in the deletion of 
loop controller devices from the project.  

For example, in Figure 5 the red text in the MicroCode dialog box indicates that 
the 3-CPU, C-CPU, and 3-SSDC1\3-SDDC1 microcode versions are unavailable. 
If you update the 3-SSDC1\3-SDDC1 microcode before updating the 3-CPU and 
C-CPU microcode, configured loop controller devices may be deleted from the 
project.  

Note: When updating the microcode, we recommend that you save the project 
as a new revision.  
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Figure 5: Unavailable microcode versions 

 

To manually update 3-SSDC1 and 3-SDDC1 microcode: 
1. Open the Project Parameter dialog box and click the MicroCode tab. 

2. Select 3-CPU or C-CPU in the Microcode Type list, and then select the 
appropriate version in the Available Application Versions list. The text 
changes to black indicating the microcode is available. 

3. After configuring the CPU microcodes, select 3-SSDC1\3-SDDC1 in the 
Microcode Type list, and then select the appropriate available application 
version. 

4. In the Warning message dialog box, click Yes to change the application code. 

14.17 Common supervisory contacts issue with SIGA2-PHS detectors 
For a SIGA2-PHS detector, if you do not restore the photo sensor prior to 
bypassing the sensor, you may inadvertently latch the 3-CPU/C-CPU's common 
supervisory contacts and the first supervisory event, which will then require a 
panel restart to restore the state of the contact and first supervisory event. 

For example, if you perform the following sequence, the inadvertent latch may 
occur. 

1. Activate the photo sensor of a SIGA2 PHS detector configured as Photo is 
Supervisory | Heat is Alarmheat. 
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2. Activate the SensorBypassOn command for the detector. 

3. Restore the photo sensor. 

4. Activate the SensorBypassOff command to restore the detector’s bypass 
condition. 

To correct the issue, a restart of all panels is required to restore the common 
supervisory contact and the fire supervisory event. 

Note: The SensorBypass command works only with the SIGA2-PHS detector; it 
does not function with the SIGA-PHS detector. 

 

 

 

 


